Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000228ILNumerics[All Projects] Bugspublic2016-05-08 11:562016-05-11 10:17
Reporterho 
Assigned Toroman 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Summary0000228: BarPlot Axis Labels + Copy failing
DescriptionSetup of axis labels seems to be wrong in certain cases. Related to the Label property of ILTicks in a tick collection. The problem becomes obvious when trying to make a copy for export.
Steps To ReproduceAV:
1) Create a barplot, stacked, Size: [2,24] (two stacked bars), horizontal.
2) Rotate slightly. You may also has to very barplot render modes a couple of times.
3) Use GetCurrentScene() to derive a copy of the scene including rotations
4) Use GDI driver to save the scene.

The result is empty, because of NullReferenceExceptions being thrown.
Additional InformationOne problem relates to the axis - ticks rendering. It appears already in GetCurrentScene() -> ILTickCollection(source). here, source has 24 ticks, but only 2 labels exist in the scene graph. (Not sure, where the labels of the other ticks are coming from)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000235)
roman (developer)
2016-05-11 10:16

* Bug in ILTickCollection resolved at release 4.10
(0000236)
roman (developer)
2016-05-11 10:17

* Bug in ILTickCollection resolved, Release 4.10

- Issue History
Date Modified Username Field Change
2016-05-08 11:56 ho New Issue
2016-05-08 11:56 ho Status new => assigned
2016-05-08 11:56 ho Assigned To => roman
2016-05-11 10:16 roman Note Added: 0000235
2016-05-11 10:17 roman Note Added: 0000236
2016-05-11 10:17 roman Status assigned => resolved
2016-05-11 10:17 roman Resolution open => fixed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker