Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000242ILNumerics[All Projects] Generalpublic2016-10-06 15:192016-10-07 10:00
ReporterFSplett 
Assigned Toho 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86OSWindowsOS Version7
Summary0000242: Using GDI-Renderer with Visualization license only causes internal exception
DescriptionWe created an application with the ILNumerics Visualization Engine, having aquired licenses for said Visualization Engine.
The application has been deployed to customer computers together with the ILNumerics.Core.dll and ILNumerics.Drawing.dll, which are the only dlls used in the application adn also the only dlls usable with the given license.

When the application is set to use the GDI-Rendering mode it requires a reference to ILNumerics.Computing internally (see attached log file).
This causes the ILPanel to be empty when the ILNumerics.Computing.dll is not available.
Steps To Reproduce1. Create an application with any ILNumerics Visualizations using only ILNumerics.Core and ILNumerics.Drawing.
2. Set the Renderer to GDI mode.
3. Deploy the application on a machine without ILNumerics installation, providing the ILNumerics.Core and ILNumerics.Drawing dlls.
Additional InformationWhen adding the ILNumerics.Computing.dll to the application output, the application works as intended.

When running the application in OpenGL-Rendering mode, no reference is required and the application works as intended.
TagsNo tags attached.
Attached Fileslog file icon ILNumerics_GDI_Test_TraceLog.log [^] (3,605 bytes) 2016-10-06 15:19

- Relationships

-  Notes
(0000257)
ho (administrator)
2016-10-06 16:03

Thanks for reporting! We have updated the corresponding documentation here: https://ilnumerics.net/deploying-ilnumerics.html [^]

The observed behavior is intended by design: the computing engine module is used internally by many (if not all) toolboxes and drawing modules. One should deploy the ILNumerics.Computing.dll with the application. Regardless if you have purchased a license for it or not.
(0000258)
ho (administrator)
2016-10-07 10:00

Closed as functioning as designed.

- Issue History
Date Modified Username Field Change
2016-10-06 15:19 FSplett New Issue
2016-10-06 15:19 FSplett File Added: ILNumerics_GDI_Test_TraceLog.log
2016-10-06 16:03 ho Note Added: 0000257
2016-10-06 16:03 ho Status new => resolved
2016-10-06 16:03 ho Resolution open => fixed
2016-10-06 16:03 ho Assigned To => ho
2016-10-07 10:00 ho Note Added: 0000258
2016-10-07 10:00 ho Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker